webmaster, seo adn smo

Privatemsg - Cross Site Scripting

dev1961's picture

* Advisory ID: DRUPAL-SA-CONTRIB-2010-080
* Project: Privatemsg (third-party module)
* Version: 6.x
* Date: 2010-August-11
* Security risk: Moderately critical
* Exploitable from: Remote
* Vulnerability: Cross-Site Scripting

-------- DESCRIPTION
---------------------------------------------------------

The Privatemsg module allows to send private messages between users. The
module does not properly escape user-supplied data before displaying it,
leading to a Cross Site Scripting (XSS [1]) vulnerability. Any user with
permission to write private messages is vulnerable to attack.
-------- VERSIONS AFFECTED
---------------------------------------------------

* Privatemsg module for Drupal 6.x versions prior to 6.x-1.3

Drupal core is not affected. If you do not use the contributed Privatemsg [2]
module, there is nothing you need to do.
-------- SOLUTION
------------------------------------------------------------

Install the latest version:
* If you use the Privatemsg module for Drupal 6.x upgrade to Privatemsg
6.x-1.3 [3]

See also the Privatemsg project page [4].
-------- REPORTED BY
---------------------------------------------------------

* Ben Durbin (bdurbin) [5]

-------- FIXED BY
------------------------------------------------------------

* Ben Durbin (bdurbin) [6]
* Sascha Grossenbacher (Berdir) [7], module maintainer